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Microsoft Visio 2010 is a powerful technical diagramming program. But, as demonstrated 

many times throughout this book, powerful doesn’t have to mean complicated.  

In this article, you’ll find an introduction to help you get started with some Visio basics 

and core concepts, along with tips on how to use Microsoft Excel 2010 with Visio to 

expand your data visualization options. Many types of Visio 2010 diagrams can be created 

from, return, or otherwise interact with data.  

So, what does that mean for you? First of all, you can automatically build some types of 

diagrams from data, no drawing required. Second, several types of diagrams can integrate 

with data sources so that they update automatically based on changes in your data—

meaning that you get many more options for effective ways to graphically present data. 

And, finally, it means that you can use diagrams as a visual interface to help easily manage 

many types of data. 

Note If you work on Windows and you don’t already own Visio, you can download a free 60-

day trial of Visio 2010 Premium. Visit http://office.com/visio for a link where you can sign up 

for the trial. 

Which Edition of Visio 2010 Do You Need? 

If you install the free trial of Visio 2010, that trial is Visio 2010 Premium. There are 

three editions of Visio 2010: Standard, Professional, and Premium. It can’t hurt to try 

Premium regardless of which edition you need. But if you’re going to purchase 

Visio, it’s good to know what you get the other editions as well.  

If you want data-driven diagrams such as PivotDiagrams and the ability to link data 

dynamically to shapes, you need Professional or Premium. Both of these editions 

give you data integration tools such as those covered in this article, and some 

integration with Microsoft SharePoint 2010 and Microsoft Visio Services (including 

new Visio 2010 capabilities to publish data-driven diagrams online as interactive 

http://office.com/visio
http://technet.microsoft.com/en-us/library/ee663485.aspx
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content). The Premium edition adds integration with SharePoint workflows, new 

features such as the creation of sub-processes within a diagram and diagram 

validation, and additional business modeling templates such as those for Six Sigma.  

Check out the feature comparison of the three editions of Visio 2010. 

Visio can get far more technical than I have any intention of getting here. The purpose of 

this article is to give you an idea of what kind of power you can add to your content when 

you let Visio sink its teeth into your data. That said, I’m using Excel 2010 as the example 

data source in all cases throughout this article, but Excel is not the only possible data 

source for any of these features. Depending on the type of graphic you’re working with, 

other possible data sources can include Microsoft Access databases, SharePoint lists, 

Microsoft Exchange Server files, XML files, or delimited text files.  

Because Visio is not part of the core Microsoft Office suite, I’m not making any 

assumptions about your experience with this program. The only assumptions made here 

are that you are an advanced Microsoft Office user, that you have some experience 

creating and working with shapes in Microsoft PowerPoint, and that you can create and 

work with basic Excel PivotTables.  

Note  For an  overall list of what’s new in Visio 2010, see the Visio 2010 Feature Comparison 

table that compares Visio 2010 to the 2007 and 2003 versions. 

See Also  For help with PivotTables, check out Chapter 21, “Powerful Reporting, Easier Than 

You Think: A PivotTable Primer.” For help with Office Art drawing tools in PowerPoint (as 

well as Word and Excel), see Chapter 14, “Creating Professional Presentation Graphics.” 

Visio Essentials—A Quick Reference Overview 

Before jumping in to working with data, I think it’s important to provide a framework for 

those who don’t have much experience working in Visio. So, this section is organized to 

provide a quick reference guide for working with shapes and pages in Visio.  

Creating a Diagram 

When you begin to create a new diagram in Visio, you can start a few different ways, as 

follows: 

http://office.microsoft.com/en-us/visio/visio-edition-comparison-FX101838162.aspx
http://office.microsoft.com/en-us/visio/compare-microsoft-visio-2010-versions-FX101814621.aspx
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 Click the File tab to open Microsoft Office Backstage view, click New, and then select a 

category (such as Business or Engineering) to view available diagram types. For 

example, take a look at the available Flowchart category options. 

 

Notice that these options are referred to as templates. However, when you select a 

template, Visio does not provide a pre-created diagram but opens sets of appropriate 

shapes for you to use in creating your diagram. These sets of shapes are known as 

stencils. Depending on the diagram type, one or several stencils might be opened for 

you. For example, if you select a Workflow Diagram, six stencils are opened, as you see 

in the following image. Click the title of any stencil to reveal its shapes. 
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 Press Ctrl+N to create a blank new document with no open stencils when you first 

open a new instance of Visio, or to create another file using the most recent diagram 

type you selected.  

To open stencils if you start with a blank document, or to make additional stencils 

available to any diagram type, on the Shapes pane, point to More Shapes, and then 

point to a category to select from all available stencils. You can open stencils from any 

category regardless of the diagram type with which you start. 

 Start with a sample diagram. To do this, at the bottom of the New tab in Backstage 

view, click Sample Diagrams. 

 Some diagram types, such as PivotDiagrams and Organizational Charts, can be created 

with wizards, which are discussed later in this article. 

Working with Shapes 

Once you have a new page and the stencils you want to use, follow these key tips to help 

you work with shapes and create your diagram: 

 To add a shape to a page, drag it from the stencil to the sheet. 

 To duplicate shapes, use Ctrl+D or Ctrl+Drag, as you can for Shapes in PowerPoint. 

 You can add text to virtually any shape, including lines and connectors. To do this, just 

select the shape and begin typing. 

 You can use improved AutoConnect tools in Visio 2010 to automatically insert 

additional shapes with connectors. When you hover your mouse pointer on a shape, 

you see arrows on each side of the shape. Just click an arrow to insert a shape with 

connector in the direction of that arrow. By default, the shape will be your selected 

shape in the active stencil. 

Or, hover your mouse pointer on an arrow to see a selection of popular shapes from 

the active stencil and click to insert your preferred shape. 

 



Visualizing Data with Excel and Visio 

Page 5 of 28 

If you don’t see AutoConnect arrows when you hover your mouse pointer on a shape, 

on the View tab, in the Visual Aids group, click AutoConnect. (If this feature gets in 

your way when you’re trying to manually add shapes or connectors, you can disable it 

from this same location.) 

 Independent formatting options for shapes include text, line, fill, shadow, and even 

corner rounding—all of which are available from the Home tab, shown here.  

 

You can do quite a bit of customization with each of these—particularly text 

formatting that offers options for all of the tab categories you see in the following 

image: 

 

(Note that corner rounding options are available from the Line dialog box.) 

 Before you start to manually format shapes, however, notice that Visio has its own set 

of themes. Visio themes are separate from the document themes in PowerPoint, Word, 

and Excel. However, they have been designed in Visio 2010 to coordinate visually and 

even use the same names as many of the document themes. They also subscribe to the 

same core concept—apply several formatting attributes at once throughout one or all 

pages in a Visio file. Theme colors are also very much the same setup, providing a 

palette for fill, line, or text color options that includes the specified colors for the active 
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theme along with several variations on each color. 

In fact, the color palette in Visio 2010 looks nearly identical to the color palette in 

PowerPoint, Word, and Excel as you see here. However, as you see in the dialog box 

that follows, the mapping is not quite the same. 

 

 

To use themes, on the Design tab, in the Themes group, select a built-in theme from 

the gallery or select separate theme colors and effects from their respective galleries. 

Built-in themes can’t be customized, but you can create your own theme colors or 

effects using the option at the bottom of those galleries. 

 

o Visio 2010 supports Live Preview for many types of formatting. So you can point 

to an entry in the themes gallery to see a preview on your diagram before you 

click it. 
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o Visio Theme Effects are more detailed than effects in document themes, including 

settings for text, line, fill, shadows, and connectors. 

o If shapes don’t update when you apply theme options, right-click the shape, point 

to Format, and then click Allow Themes. This is likely to be needed in particular 

with diagrams that were originally created in earlier versions. 

o Notice that, when you apply a theme, shapes in stencils take on the default fill 

color for that theme and new content you add to the diagram will automatically 

utilize the active theme. 

 When you hover over many types of shapes, a ScreenTip automatically appears with 

the shape name. However, to add, edit, or delete ScreenTip text from any shape, on 

the Insert tab, in the Text group, click ScreenTip. 

 Many of the tools for positioning and managing shapes are available on the Home 

tab, in the Arrange group, as you see here. 

 

o Grouping, order, rotation and flip options for Visio shapes are virtually identical to 

PowerPoint. Notice rotation options on the Position menu, under Orient Shapes. 

Flip options are available on the Rotate … submenus. 

o Alignment options appear to be identical to those in PowerPoint, but they work a 

bit differently. Instead of aligning to whichever shape is farthest in the direction to 

which you’re aligning (such as aligning the tops of shapes by whichever shape is 
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highest on the page), Visio shapes are aligned to whichever shape you select first. 

(You’ll notice that the selection outline for the dominant shape is thicker than for 

other shapes in your selection.) 

o The Space Shapes options on the Position menu include distribution tools (to 

distribute selected shapes horizontally or vertically) as well as the new Auto 

Alignment tool that you also see as a separate command in this group. 

The Auto Space or Auto Align & Space commands attempt to provide automatic 

arrangement of selected shapes and connectors. Though I’m not usually a fan of 

features that seem to try to guess what I’m thinking, this tool is worth a try if you 

need a fairly standard diagram layout. You can always undo (Ctrl+Z) if you don’t 

like the result. 

 To resize shapes or place them at a particular position on the page, use the Size & 

Position Window. This window is one of several handy tools available from the 

improved Status bar.  

o When a shape is selected, you see Height, Width, and Angle on the Status bar by 

default. Click any of these values to open the Size & Position window, shown here. 

 

o On the right side of the Status bar, you see several view options by default, 

including the familiar Zoom slider, a Fit Page shortcut much like the Fit Slide 

shortcut in PowerPoint, and a smart Pan & Zoom window that helps you zoom 

straight to what you need (very handy for larger diagrams that don’t fit in your 

window), as you see here. 
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You can drag the red rectangle that appears in this window to resize it to 

where you want to zoom. Or drag in the window as if you were dragging to 

marquee content on the page, to marquee the portion of the diagram to 

which you want to zoom. 

 Many tools that you are likely to think of as drawing tools are on the Developer tab in 

Visio 2010, in the Shape Design group shown in the following image: 

 

As with other Office 2010 programs, enable the Developer tab in Visio from the 

Customize Tab of the Visio Options dialog box. (To quickly access this dialog box, 

right-click any Ribbon command then click Customize the Ribbon.) 

o If a shape won’t do what you need it to do, such as allow resizing, protection is 

most likely in place. To change protection settings for selected shapes, click 

Protection and then change the settings as needed. 

o When you click the Behavior command, you see the following dialog box. The 

granularity of control for shape behavior that you see here gives you a glimpse 

into the power and flexibility of Visio diagrams. 

Open Pan & Zoom window
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Note  If you get frustrated by the behavior of shapes jumping out of your way when 

you drop or move other shapes on the sheet, use the options on the Placement tab of 

the Behavior dialog box to control those actions. 

o One of my favorite Visio tools is the Operations group of functions. For example, 

draw lines horizontally through a triangle (you can find a straight line on the 

Drawing toolbar), for example, and then use the Fragment tool for creating the 

perfect pyramid diagram. Just draw lines that completely cross the shape, then 

select the shape with all lines and click Fragment.  

 

Notice that some of these operations are now available in PowerPoint, as part of 

the new Combine Shapes tools addressed in Chapter 14. Operations in Visio 

provide more options than those in PowerPoint, such as the Fragment tool 

described earlier. 

Note that shapes created using Operations become independent, fully functional 

shapes. So, you can add text to the new shapes or apply whatever formatting you 

need. Try out the various Operations with a few different shapes to see what you 

can do.  
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Hyperlink Between Shapes in a Visio File 

You can add hyperlinks to Visio shapes to link to external files or Web addresses, or 

to link to other shapes within the same Visio diagram or file. This is particularly 

useful if, for example, you plan to publish your diagram on a Web page for use as 

an interactive tool. To add a hyperlink, select a shape and then, on the Insert menu, 

click Hyperlinks (or press Ctrl+K). 

External addresses are quite straightforward to add—just browse to or type the 

location, add a description (which appears as the hyperlink ScreenTip), and then 

click OK. Internal address, however, require a bit more information.  

To add a link to another shape, you can type the page name, a forward slash, and 

then the shape name. Or, you can click Browse to select the sheet name, then type 

the shape name, and Visio sets up the syntax for you. Either way, however, you need 

to know the shape name. 

If you only have one shape of a given type on the sheet, the shape name is the same 

as the shape name in the stencil. On the Developer tab, in the Shape Design group, 

click Shape Name to view or change the name of the shape. 

Alternately, you can get the shape name from the title bar on the Shape Sheet—and 

you can edit the hyperlink from the Shape Sheet as well. On the Developer tab, in 

the Shape Design group, click Show Shape Sheet. Learn more about using Shape 

Sheets in the following tip. 

 

Manage a Surprising Array of Settings from the Shape Sheet 

Every shape and every page in a Visio file has its own Shape Sheet. This sheet is a 

collection of various settings available to the shape or page, ranging from height, 

width, and position, to rotation angle, fill color, and then some. There are many 

technical details on the Shape Sheet that you might not recognize, but you can edit 

anything you recognize from that sheet instead of through individual dialog boxes. 

The sheet is organized like a spreadsheet, as you see in the following image. Click 

the heading of any section on the sheet to expand or collapse it. You can click into 
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any cell to change a value. Or, use the Formula Bar that becomes available beneath 

the Shape Sheet Tools Design tab when your insertion point is in a Shape Sheet. 

 

One interesting option available here is to change the skin color appearance of 

shapes that represent people, as you see in the preceding image. Colors are shown 

in the Shape Sheet using the HSL color model, but RGB values are also accepted.  

Using Connectors 

You can add connectors using the AutoConnect tool discussed in the preceding section, 

or add them manually, as follows: 

 On the Home tab, in the Tools group, click Connector. While active, your insertion 

point adds connectors whenever you drag between two shapes. Hover over a shape 

until you see a red box around it, then drag to the shape where you want the 

connector to end. 
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 Select a connector from a stencil. Many stencils offer the Dynamic Connector, which 

you can drag to the sheet and then drag each end over the shape where you want it 

to connect. When a red box appears highlighting the destination shape, release the 

mouse pointer.  

 Some stencils offer multiple connector types. However, a Connector stencil also exists. 

On the Shapes pane, point to More Shapes, and then point to Visio Extras to access 

this stencil. Note that not all connectors are dynamic. Those that are not won’t provide 

the red box indicator to release the pointer. 

However, with any connectors—dynamic or not—you can take advantage of what 

Visio calls Snap To Geometry, which refers to the drawing grid. Snap To Geometry 

enables you to place a connector end virtually wherever you want it, and it stays put. 

 You can change connector types and set many options, from the number of sides of a 

connector to causing jumps to appear when connectors cross. Do this on the 

Connector tab of the Behavior dialog box. To access this dialog box, Developer tab, in 

the Shape Design group, click Behavior.  

 

Note that not all types of connectors will provide the Connector tab in this dialog box. 

An alternative entry point for managing line jumps is in the Page Setup dialog box, on 

the Layout & Routing tab. To access this dialog box, on the Design tab, in the Layout 

group, click the dialog launch icon. 
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Formatting Pages 

On the Design tab, in the Page Setup group (or the Layout group), click the dialog launch 

icon to open the Page Setup dialog box. This dialog box provides many familiar page 

formatting options, such as Print Setup and Page Size. For some layout options, you can 

also set defaults for the page as well as the depth and position of shadows when applied 

to shapes.  

 

However, in addition to the typical settings you’d expect to find in a Page Setup dialog 

box, and some Visio oddities such as the shadow defaults, two items will especially come 

in handy: 

 If you’re creating a diagram to add to a document in another program, consider 

setting a custom page size to match the size allotted to the diagram in the destination 

document. Then, you can zoom in on the available space to ensure that you create 

your diagram to fit. For example, use the dimensions of a placeholder table cell in a 

Word document. 

Alternatively, Visio gives you options for sizing your page to fit your diagram. After the 

diagram is created, on the Design tab, in the Page Setup group, click Size and then 

click Fit To Drawing. Visio 2010 also introduces the Auto Size feature that you find in 

the Page Setup group, which automatically expands the page as needed while you 

create the diagram to accommodate your drawing. 



Visualizing Data with Excel and Visio 

Page 15 of 28 

Note To copy a Visio diagram for pasting into another program, don’t select the diagram 

unless you’re only taking some content on the page. For best and most consistent results 

when you want to copy all page content for pasting into another program, just press Ctrl+C to 

copy without first selecting anything. To paste Visio diagrams into Word 2010 or PowerPoint 

2010, press Ctrl+Alt+V in the destination program to open the Paste Special dialog box. Then, 

for best quality, select either Picture (Enhanced Metafile) or Device Independent Bitmap as the 

paste type. The Windows Metafile option may not provide good resolution for Visio graphics 

pasted into other Microsoft Office programs. (If you prefer a PNG picture, which may reduce 

file size, you can cut the picture after pasting it into Word or PowerPoint and then use Paste 

Special again, where you’ll see PNG as a picture type option.) 

 On the Page Properties tab, you can name the page, set unique measurement units to 

use for the page, identify a page as a background or foreground page, and apply a 

background page. 

Background pages in Visio are where you place content that you want to appear on 

one or more sheets but not be editable from those sheets. This is a nice place for 

template design elements, such as logos or headers and footers. Background pages 

are also the place to add a watermark. Once you set a page as a background page, it 

then becomes available to be applied to other pages. 

In addition to Page Setup properties, keep the following in mind for working with Visio 

pages. 

 Double-click a page tab to rename the page. Or, right-click the page tab for the 

options to add, delete, rename, or reorder pages. 

 To add drawing guides to the page, hover over the bottom edge of the horizontal 

ruler or the right edge of the vertical ruler until you see a double-backed black arrow. 

The position of the guide appears on the Status bar as you drag the guide. To delete a 

guide, just select it and then press Delete. 

 As mentioned earlier, each page also has its own Shape Sheet that you can access 

when you right-click the page. On the Shape Sheet, you can set a number of 

properties, such as page size, margins, or grid density.  

Creating a Visio Organization Chart from Worksheet 
Data 

This feature has been around for a few versions of Visio, but it is nonetheless pretty 

impressive. Just type a list of names, titles, and managers in an Excel worksheet and Visio 

will create even the most extensive organization chart for you in a couple of clicks.  
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Note Depending upon your needs for an organization chart, you might want to use this 

feature or use SmartArt diagrams that are discussed in several places throughout the book, 

and in detail in Chapter 14. For large, intricate organization charts, Visio is the more flexible 

choice. But, when you create SmartArt diagrams in PowerPoint, you can convert a bulleted list 

to a diagram in just a few clicks and then add or revise shapes just by typing and adding or 

removing bullets in the SmartArt text pane.  

Visio is also a better choice when you want to store data in diagrams or create diagrams that 

are interactive, such as diagrams with hyperlinks published on a Web page. But, if you just 

need a high-quality, simple organization chart to add to a document without having to draw 

any shapes, consider whether a SmartArt diagram might not do the trick for you more easily. 

Also, unlike Visio diagrams, SmartArt diagrams use document themes, are live, editable objects 

in your PowerPoint, Word, or Excel documents, and are cross-platform compatible (for those 

who share content with Mac users).  

To create a Visio organization chart from data stored in Excel, do the following. 

 1. Set up your data in Excel in columns with a single row of headings. Headings will 

become field names for use in creating the organization chart. The only required 

fields are a field for the person’s name and a field for the person to whom they 

report. Include other fields as needed for content you want to include in your chart, 

as you see in the following sample data. 

 

For the Organization Chart Wizard to map the diagram correctly, the name of the 

person reported to must be typed the same in the Reports To field as it is where it 

appears in the Name field. When you’ve finished setting up the data, close the Excel 

file. Visio will not be able to access the file if it’s open in Excel. 

 2. In Visio, click the File tab, click New, and then click Business. Select Organization 

Chart Wizard and then click Create. 

 3. When the wizard opens, click Next at the first screen to select data from an existing 

source file. Notice that data can be in an Excel file, a text file, an Exchange Server 

directory, or a database. At the second screen, select the option that includes Excel 
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File and then click Next again. Browse to and select your file, and then click Next 

once more. 

 4. Once Visio accesses your data, it will attempt to match field names (column 

headings) to the Name and Reports To fields for the organization chart. Confirm 

that Visio has selected the correct fields and then click Next. 

At this point, you can just click Next until the Finish button becomes available and 

then click Finish to generate your chart. However, take note of the options at each 

wizard screen between. On the last wizard screens, you can specify fields from your 

data to display on the chart and the order in which to display them within shapes, 

select fields to store in shapes as Shape Data (see the section “Using Shape Data and 

Data Graphics” for more on Shape Data), and specify layout requirements. 

When the organization chart is generated from the sample data shown in the preceding 

steps, it looks like this. 

 

It takes just two more clicks to format this chart with theme colors and effects. You can 

then add shapes from the Organization Chart Shapes or any other stencil and format 

them as you would any Visio shape. You can also use options on the Org Chart tab of the 

Ribbon shown here (this menu appears only for this diagram type), including the 

following: 

 

 Select Display Options to globally apply format settings, such as shape size and text 

formatting for each visible field (such as italicizing titles). 

 Change the position type (such as executive or manager) for selected shapes. 
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 Click Export to export all data from your completed organization chart to a new Excel 

file. Just type a name for the new file and click Save.  

Note that this works just as well with organization charts you create from other 

sources or by drawing shapes. So, for example, if you create your organization chart 

from Excel data and then add shapes to the chart manually in Visio, when you export 

that data to Excel, it will include the shapes you’ve added as well as those that were 

automatically generated. Also note that, by default, the exported file is saved as an 

.xlsx file. 

Creating a PivotDiagram 

A PivotDiagram is just what it sounds like—a diagram that displays data just like an Excel 

PivotTable or PivotChart. A PivotDiagram is a hierarchal diagram (similar to the structure 

of an organization chart) that remains connected to data, so that you can look at the data 

visually in as many different configurations as your data allows. 

Generating a PivotDiagram 

Note This section uses the same sample data that was used for PivotTables in Chapter 21. Find 

the file Pivot Data.xlsx in the Chapter21 sample files folder available along with the Bonus 

Content folder that contains this article, at http://oreilly.com/catalog/9780735651999/. 

To create your PivotDiagram, start with data set up in Excel as for a PivotTable (data in 

columns with a single row of headings and values in all cells) and then do one of the 

following: 

 If your Excel data is formatted as a table, on the Table Tools Design tab, click the 

Export options and then click Export Table To Visio PivotDiagram.  

 Whether your Excel data is formatted as a table or a range, you can also create your 

PivotDiagram from Visio. To do this, click the File tab, click New, and then click 

Business. Select PivotDiagram and then click Create.  

Follow the wizard to select your Excel file and, if necessary, select the specific sheet or 

range in that file. Then, just keep clicking Next until the Finish option appears. Click 

Finish to create your table.  

When you create the PivotDiagram using this wizard, source data can originate in an 

Excel workbook, an Access database, a SharePoint list, a SQL Server Database, or 

http://oreilly.com/catalog/9780735651999/
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another OLEBD (Object Linked Embedded Database) or ODBC (Open Database 

Connectivity) compatible data source. 

With either of the preceding methods, the PivotDiagram page is generated with a single 

shape to designate the top level of the diagram and a shape identifying the source data, 

last update, and any filters in place, as shown in the following image: 

 

Notice that all available fields for the PivotDiagram are provided in the PivotDiagram 

pane, divided into Categories (the equivalent of Row or Column fields in a PivotTable) and 

Totals (the equivalent of Value fields in a PivotTable). 

Formatting and Managing a PivotDiagram 

Just click to apply a category from the PivotDiagram pane to the page and Visio will 

generate the applicable shapes. Also in the pane, select the totals you want to appear in 

each shape. In the following example, training cost per person is shown by business area.  
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Note  If your diagram seems to display an inaccurate empty entry for a selected category, turn 

off the totals row in the source Excel table. 

Following are some key tips to help you create the PivotDiagram you need: 

 The Total in the preceding PivotDiagram example is listed as Cost This Person because 

this is the name of the applicable column heading in the Excel data. But, because 

you’re actually showing total training cost for the department in this case, you might 

want to change the field name. To change the name of any Category or Total field as 

it will appear in the diagram, click the arrow that appears when you point to the field 

in the PivotDiagram pane and then click Configure Column. Edit the name as needed 

and click OK. The field name will automatically change throughout the table.  

 To break out the categories further, select the shapes representing the categories you 

want to break out and then click the category for which you want to see the detail. For 

example, to show cost per person in the business development department, select the 

Business Development shape that contains the total and then click Name in the 

PivotDiagram pane. The result looks like this. 
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Because you can show detail for individual shapes, you must select all shapes in a 

category when you want to add a new subcategory for all. Be sure to select the part of 

the shape that contains the total and not the shape heading. To quickly select all 

shapes in the category, point to the category name in the PivotDiagram pane, click the 

drop-down arrow that appears, and then click Select All. 

 You can format and resize shapes just as you would any shapes in a Visio diagram. To 

resize several shapes at once, select all shapes to be resized and then drag from the 

handles surrounding the selection to resize them as a group. 

 To change the number format for totals, on the PivotDiagram tab of the Ribbon, click 

Edit Data Graphic. Then, do the following: 

 1. Select the Data Graphic that contains the field name for which you want to 

change the format and then click Edit Item.  

 2. In the Value Format field, click the ellipsis to open a Data Format dialog box, 

where you can specify the number format you need.  

For more detail on working with Data Graphics, see the next section. 

 The shapes in a PivotDiagram that contain the totals for each shape in a category are 

known as Pivot Nodes. You can apply more interesting shapes to Pivot Nodes by using 

the Apply Shape option on the PivotDiagram tab. Just select the Pivot Nodes to which 

you want to apply a shape, and then in the Apply Shapes dialog box, click a shape and 

then click OK. Shapes from the Departments and Workflow Objects stencils are 

available automatically through this dialog box.  

 To access filter options for any field in the diagram, click the arrow that appears when 

you point to a field in the PivotDiagram pane and then click Configure Column.  

 From the PivotDiagram tab, you can manage the diagram layout, sort selected shapes 

in the diagram, merge selected shapes into a single shape (this can be a great way to 

save space when you want to break out several categories in a single diagram), and set 

a variety of options for your PivotDiagram.  

On the PivotDiagram tab, in the Show/Hide group, you can change the name of the 

table, choose to show or hide diagram elements, or click the dialog launch icon to 

open the PivotDiagram Options dialog box that provides additional configuration 

options (including the option to revise your data source).  
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Using Shape Data and Data Graphics 

You can create shape data directly in Visio or generate it automatically from a variety of 

sources. Additionally, you can add data graphics to display this data directly on shapes. 

Note As mentioned earlier, the dynamic content in a PivotDiagram is created as data graphics. 

To edit a data graphic that appears in your PivotDiagram, on the PivotDiagram tab, click Edit 

Data Graphic. 

To create Shape Data from an external source, use data originating in an Excel workbook, 

an Access database, a SharePoint list, a SQL Server Database, or another OLEBD or ODBC 

compatible data source. 

Creating Shape Data 

Shape Data is information you store in shapes on your diagram. For example, you might 

want to store serial number and location information for computer equipment that 

appears in a floor plan diagram of your office.  

In addition to displaying Shape Data in a Data Graphic, you can export data from shapes 

into a report generated as an Excel workbook, an HTML file, an XML file, or a shape on 

your active Visio page. 
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To create Shape Data, select one or more shapes to which you want to add data, right-

click the selection, point to Data, and then click Define Shape Data.  

 

In the Define Shape Data dialog box shown here, you can add, delete, and edit existing 

shape data properties. 

When your shapes contain shape data, you can also display the Shape Data window 

through which you can see and edit data for selected shapes. In the Shape Data window 

shown here, the selected shape contains Shape Data properties labeled Name and 

Location, neither of which as yet has a value. You can add that value directly in this 

window or in the Define Shape Data dialog box. 

 

Note Notice an option in the Define Shape Data dialog box labeled Ask On Drop. If you check 

this option for a Shape Data property, you’ll be prompted to add or edit the value of that 
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property when you duplicate the shape. You must enable this option separately for each 

property that you want to appear in the prompt. 

Each field you add to Shape Data is called a property. To add more than one property for 

selected shapes, click New at the bottom of the Define Shape Data dialog box. If you need 

to edit existing Shape Data properties, select the item to edit from the Properties list in 

the Define Shape Data dialog box. 

Note Some types of shapes, such as those in the Office Equipment stencil, come with built-in 

Shape Data properties. These properties work exactly the same as the Shape Data properties 

you create. If you don’t want to use the built-in properties, in the Define Shape Data dialog 

box, select individual unwanted properties and then click Delete.  

Generating a Data Report 

To generate a report of all Shape Data in the active diagram or the entire workbook, first 

create a custom report and then run that report as needed. To do this, on the Review tab, 

click Shape Reports and then click New. Then, do the following: 

 1. In the Report Definition Wizard, choose to create your report for all shapes on the 

current page, in the entire file, or just selected shapes and then click Next. 

You can also click Advanced on this first wizard screen to filter the shapes included in 

the report. 

 2. Built-in shape properties as well as the custom Shape Data properties you define are 

available on the second wizard screen. Select the properties to include in your report 

and then click Next to continue through the wizard. You’ll have the opportunity to 

name the report and to set other properties such as subtotals or sorting options, as 

applicable, and then click Finish. 

 3. Once your custom report appears in the Reports dialog box, select it and then click 

Run. You’ll be prompted to choose output as Excel, HTML, Visio Shape, or XML. 

When you choose Excel, HTML, or XML, the report is generated as a separate file. 

Linking Data to Shapes 

As an alternative to creating and editing Shape Data directly on shapes, you can import 

that data from another source.  

Note External source data for linking to shapes should be arranged in columns with a single 

row of headings.  
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To import data, on the Data tab, click Link Data to Shapes. In the wizard that opens, locate 

and select your data source. Once you’ve specified the data source, you can simply click 

Finish to import the data, or follow the wizard through to specify data fields to import or a 

field to use as a unique identifier when refreshing data. 

The data appears in the External Data pane, which opens below the page by default, as 

shown here. 

 

To link your imported data to shapes, do one of the following. 

 Select the shape you want to use in the active stencil, but don’t drag the shape to the 

page. Then, drag rows from your data onto the page. One shape will be generated for 

each row of data, and the linked data will be stored in the shapes as Shape Data. 

 If shapes already exist to which you want to link data, drag a row of data to the shape 

that you want to link. A box will appear around the shape when the data is ready to be 

dropped. Just release the mouse button to link the data to the selected shape. 

When a row is linked to a shape, a link icon appears at the beginning of the row in the 

External Data pane. You can double-click in a linked row to select its linked shape on the 

page. Or, right-click a shape containing linked data, then point to Data for the option 

Show Linked Row, which selects the linked row in the External Data pane. 

Note On the Data tab, in the External Data group, click the arrow beneath the Refresh All 

Command, click Refresh Data, and then click Configure for the option to edit the source data 

range, set up automatic refresh, or set the data refresh to override changes users make to 

Shape Data. 
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Automatically Link Imported Data to Shapes 

Once you import data using Link Data To Shapes, as discussed in the preceding 

steps, you can use the Automatically Link feature to add that data to shapes on the 

sheet. Well, that’s almost true.  

The catch to the Automatically Link feature is that you must have a Shape Data 

property in each shape that corresponds to one field name and a corresponding 

value in the imported data in order for Automatically Link to work. Of course, it’s 

logical that Visio would need a field to match in order to know which data record to 

link to which shape. But, because there is some manual data entry involved in this 

method, decide based on your particular data and diagram whether Automatically 

Link or dragging records from imported data to specific shapes is going to be the 

more efficient option for your needs. 

To use Automatically Link, first create a Shape Data property in the shapes to be 

linked that matches one of the fields in the imported data, and then enter the 

corresponding value from an imported data record into the Shape Data of each 

shape. Once you have a property value in the Shape Data that matches a field of the 

same name in a record of the imported data, on the Data tab, in the External Data 

group, click Automatically Link. Then follow the prompts to automatically link all 

remaining fields from the imported data to your shapes. 

Creating and Managing Data Graphics 

Once your shapes contain Shape Data, you can add Data Graphics to them to display the 

data along with the shape. Data Graphics can display as text (this is the type of Data 

Graphic used to generate PivotDiagrams) or can be displayed as data bars, icon sets, or 

color shapes by value. 

Note When you link external data to shapes, text data graphics may be added to the shapes 

automatically. You can edit or delete these in the Edit Data Graphic dialog box as well. Or, to 

delete all Data Graphics from selected shapes, right-click, point to Data, and then click 

Remove Data Graphic.  

To create or edit a Data Graphic, select applicable shapes. On the Data tab, in the Display 

Data group, click Data Graphics, and then click either Create New Data Graphic or Edit 

Data Graphic. Then do the following: 
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Note  When you click Data Graphics, you see a gallery of existing, available data graphics. You 

can right-click any gallery entry for the option to rename, duplicate, edit, or delete that data 

graphic. 

 1. Click New Item and then select the type of Data Graphic you want. In the New 

<Graphic Type> dialog box, select the field that you want the graphic to display. 

Fields refer to the Shape Data properties available for the selected shape. Notice 

also that you can click More Fields in the Data Fields drop-down list to select 

additional options for your data graphic, including creating a custom formula. 

 2. Specify the formatting details for the data graphic. Available options vary by graphic 

type, including the following: 

o Text, data bar, or icon set graphics appear as callouts that you can place on top of 

or adjacent to the shape by using the Callout Position options. The Color By Value 

option actually changes the color of the shape to which the data is attached. 

o You can set the Value Format (such as a number format) for text or data bars. For 

icon sets and colors, assign specific values from the selected field to represent 

each available color or icon. 

o The callout display for text or data bars can take on a variety of graphic forms. 

Once you’ve applied all of the settings you want, click OK twice to apply the graphic. 

Once you create a Data Graphic for shapes in a file containing linked data, new shapes 

created from that linked data will take on those graphics automatically. To disable this 

option, on the Data tab, click Data Graphics and then clear the option Apply After Linking 

Data To Shapes. 

More Visio Data Connections 

Several additional data integration options exist for Visio diagrams, beyond those 

discussed here. For example, you can generate a Brainstorming diagram from XML data or 

export data from a Brainstorming diagram to Word, Excel, or an XML file.  

Other common data integration options include creating a Gantt chart from project 

management data or a calendar from Microsoft Office Outlook data. Both of these are 

available from the Schedule Template Category on the New tab in Backstage view.  
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And, as mentioned earlier, Visio can get far more dynamic, including the ability to publish 

diagrams as interactive content online and integrate diagrams with SharePoint workflows. 

Visit http://office.com/visio to learn more.  

http://office.com/visio

